UE4版本和vs版本的对应关系

发布于:2021-05-18 12:33:42

查找UEBuildWindows.cs文件,里面记录了此版本的UE4可以用哪个版本的VS编译


比如


4.19.1版本


public enum WindowsCompiler
{
///


/// Use the default compiler. A specific value will always be used outside of configuration classes.
///

Default,

///
/// Visual Studio 2013 (Visual C++ 12.0)
///

[Obsolete("UE4 does not support building Visual Studio 2013 targets from the 4.16 release onwards.")]
VisualStudio2013,

///
/// Visual Studio 2015 (Visual C++ 14.0)
///

VisualStudio2015,

///
/// Visual Studio 2017 (Visual C++ 15.0)
///

VisualStudio2017,
}

4.9版本


public enum WindowsCompiler
{
/// Visual Studio 2012 (Visual C++ 11.0). No longer supported for building on Windows, but required for other platform toolchains.
VisualStudio2012,

/// Visual Studio 2013 (Visual C++ 12.0)
VisualStudio2013,

/// Visual Studio 2015 (Visual C++ 14.0)
VisualStudio2015,
}


相关推荐

最新更新

猜你喜欢